Skip to content

Release history for the Splunk Add-on for Microsoft SCOM

The latest version of the Splunk Add-on for Microsoft SCOM is version 4.4.0. See Release notes for the Splunk Add-on for Microsoft SCOM for the release notes of this latest version.

Version 4.3.2

Version 4.3.2 of the Splunk Add-on for Microsoft SCOM was released on January 6, 2024.

Compatibility

Version 4.3.2 of the Splunk Add-on for Microsoft SCOM is compatible with the following software, CIM versions, and platforms:

Component Description
Splunk platform versions 8.1.x, 8.2.x. 9.0.x
CIM 5.0.0
Platforms Windows
Vendor Products Microsoft System Center Operations Manager 2019

Microsoft System Center Operations Manager 2022

Note

The field alias functionality is compatible with the current version of this add-on. The current version of this add-on does not support older field alias configurations.

For more information about the field alias configuration change, refer to the Splunk Enterprise Release Notes.

New features

Version 4.3.2 of the Splunk Add-on for Microsoft SCOM has the following new features:

  • Updated certification to 2023.11.17.
  • Updated urllib3 to 1.26.18 and semver.

Fixed issues

Version 4.3.2 of the Splunk Add-on for Microsoft SCOM fixes the following issues. If no issues appear in this section, no issues have yet been fixed.

Known issues

Version 4.3.2 of the Splunk Add-on for Microsoft SCOM contains the following known issues.

If no issues appear in this section, no issues have yet been reported.

Version 4.3.1

Version 4.3.1 of the Splunk Add-on for Microsoft SCOM was released on February 17, 2023.

Compatibility

Version 4.3.1 of the Splunk Add-on for Microsoft SCOM is compatible with the following software, CIM versions, and platforms:

Component Description
Splunk platform versions 8.1.x, 8.2.x. 9.0.x
CIM 5.0.0
Platforms Windows
Vendor Products Microsoft System Center Operations Manager 2019

Microsoft System Center Operations Manager 2022

Note

The field alias functionality is compatible with the current version of this add-on. The current version of this add-on does not support older field alias configurations.

For more information about the field alias configuration change, refer to the Splunk Enterprise Release Notes.

New features

Version 4.3.1 of the Splunk Add-on for Microsoft SCOM has the following new features.

  • Upgraded the certifi library to version 2022.12.7
  • Fixed a security vulnerability found in the certifi library

Fixed issues

Version 4.3.1 of the Splunk Add-on for Microsoft SCOM fixes the following issues. If no issues appear in this section, no issues have yet been fixed.

Known issues

Version 4.3.1 of the Splunk Add-on for Microsoft SCOM contains the following known issues.

If no issues appear in this section, no issues have yet been reported.

Version 4.3.0

Version 4.3.0 of the Splunk Add-on for Microsoft SCOM was released on October 17, 2022.

Compatibility

Version 4.3.0 of the Splunk Add-on for Microsoft SCOM is compatible with the following software, CIM versions, and platforms:

Component Description
Splunk platform versions 8.1.x, 8.2.x. 9.0.x
CIM 5.0.0
Platforms Windows
Vendor Products

Microsoft System Center Operations Manager 2019
Microsoft System Center Operations Manager 2022

Note

The field alias functionality is compatible with the current version of this add-on. The current version of this add-on does not support older field alias configurations.

For more information about the field alias configuration change, refer to the Splunk Enterprise Release Notes.

Upgrade guide

Version 4.3.0 of the Splunk Add-on for Microsoft SCOM is backwards compatible with version 4.2.0. All source types are the same and all inputs created using version 4.2.0 will continue to function.

New features

Version 4.3.0 of the Splunk Add-on for Microsoft SCOM has the following new features.

  • Direct events processing using SQL queries instead of Powershell scriptlets.
  • CIM enhancements for performance events.

Fixed issues

Version 4.3.0 of the Splunk Add-on for Microsoft SCOM fixes the following issues. If no issues appear in this section, no issues have yet been fixed.

Known issues

Version 4.3.0 of the Splunk Add-on for Microsoft SCOM contains the following known issues.

If no issues appear in this section, no issues have yet been reported.

Version 4.2.0

Version 4.2.0 of the Splunk Add-on for Microsoft SCOM was released on February 28, 2022.

Compatibility

Version 4.2.0 of the Splunk Add-on for Microsoft SCOM is compatible with the following software, CIM versions, and platforms:

Component Description
Splunk platform versions 8.0.x, 8.1.x, 8.2.x
CIM 4.18.1
Platforms Windows
Vendor Products Microsoft System Center Operations Manager 2016

Microsoft System Center Operations Manager 2019

Note

The field alias functionality is compatible with the current version of this add-on. The current version of this add-on does not support older field alias configurations.

For more information about the field alias configuration change, refer to the Splunk Enterprise Release Notes.

Upgrade guide

Version 4.2.0 of the Splunk Add-on for Microsoft SCOM is backwards compatible with version 4.1.1. All source types are the same and all inputs created using version 4.1.1 will continue to function.

New features

Version 4.2.0 of the Splunk Add-on for Microsoft SCOM has the following new features.

  • Updated deprecated SCOM SDK functions for collecting performance data with newly supported Microsoft Functions.
  • Added support for configuring filter parameters in performance data inputs.
  • Added Server validation on server configuration page.
  • Updated UI to show warning sign on inputs page for missing server/templates in the configured inputs.
  • Updated behavior to allow deletion of servers that are being used by inputs.
  • Minor Bug Fixes and UI enhancements.

This release introduces changes on the Inputs page, where a new field filter parameter has been added for performance based templates.

For more information about these changes and the configuration guide, refer to the Configure Inputs page.

Fixed issues

Version 4.2.0 of the Splunk Add-on for Microsoft SCOM fixes the following issues. If no issues appear in this section, no issues have yet been fixed.

Known issues

Version 4.2.0 of the Splunk Add-on for Microsoft SCOM contains the following known issues.

If no issues appear in this section, no issues have yet been reported.

Version 4.1.1

Version 4.1.1 of the Splunk Add-on for Microsoft SCOM was released on July 30, 2021.

Compatibility

Version 4.1.1 of the Splunk Add-on for Microsoft SCOM is compatible with the following software, CIM versions, and platforms:

Component Description
Splunk platform versions 8.0.x, 8.1.x, 8.2.x
CIM 4.18.1
Platforms Windows
Vendor Products Microsoft System Center Operations Manager 2012 R2

Microsoft System Center Operations Manager 2016
Microsoft System Center Operations Manager 2019

Note

The field alias functionality is compatible with the current version of this add-on. The current version of this add-on does not support older field alias configurations.

For more information about the field alias configuration change, refer to the Splunk Enterprise Release Notes.

Upgrade guide

Version 4.1.1 of the Splunk Add-on for Microsoft SCOM is backwards compatible with version 4.0.0. All source types are the same and all inputs created using version 4.0.0 will continue to function.

Some events might be duplicated when you upgrade the Splunk Add-on for Microsoft SCOM on Splunk 7.3.x while the modular input script is running.

New features

Version 4.1.1 of the Splunk Add-on for Microsoft SCOM has the following new features.

  • Fast and intuitive UI with an improved look and feel.
  • Provides critical security fix by removing jquery2.
  • Removal of python2 support. Only python3 is supported from now on.
  • Changed add-on default landing page to configuration page.
  • Changed default value of Start Time field to one day before current UTC time.

Fixed issues

Version 4.1.1 of the Splunk Add-on for Microsoft SCOM fixes the following issues. If no issues appear in this section, no issues have yet been fixed.

Known issues

Version 4.1.1 of the Splunk Add-on for Microsoft SCOM contains the following known issues.

If no issues appear in this section, no issues have yet been reported.

Version 4.0.0

Version 4.0.0 of the Splunk Add-on for Microsoft SCOM was released on February 17, 2021.

Compatibility

Version 4.1.0 of the Splunk Add-on for Microsoft SCOM is compatible with the following software, CIM versions, and platforms:

Component Description
Splunk platform versions 8.0.x, 8.1.x, 8.2.x
CIM 4.18.1
Platforms Windows
Vendor Products Microsoft System Center Operations Manager 2012 R2

Microsoft System Center Operations Manager 2016
Microsoft System Center Operations Manager 2019

Note

The field alias functionality is compatible with the current version of this add-on. The current version of this add-on does not support older field alias configurations.

For more information about the field alias configuration change, refer to the Splunk Enterprise Release Notes.

Upgrade guide

Version 4.1.0 of the Splunk Add-on for Microsoft SCOM is backwards compatible with version 4.0.0. All source types are the same and all inputs created using version 4.0.0 will continue to function.

Some events might be duplicated when you upgrade the Splunk Add-on for Microsoft SCOM on Splunk 7.3.x while the modular input script is running.

New features

Version 4.0.0 of the Splunk Add-on for Microsoft SCOM has the following new features.

  • Changed add-on default landing page to configuration page.
  • Support for Microsoft System Center Operations Manager 2019
  • Added a lookup for the “type” field of the Alerts CIM Data Model.
  • Enhanced compatibility for the Common Information Model (CIM) by removing these field extractions from the alert events, since these fields are automatically provided by asset and identity correlation features using applications like Splunk Enterprise Security:
  • dest_bunit
  • dest_category
  • dest_priority
  • src_bunit
  • src_category
  • src_priority

Fixed issues

Version 4.0.0 of the Splunk Add-on for Microsoft SCOM fixes the following issues. If no issues appear in this section, no issues have yet been fixed.

Known issues

Version 4.0.0 of the Splunk Add-on for Microsoft SCOM contains the following known issues.

If no issues appear in this section, no issues have yet been reported.

Version 3.0.2

Version 3.0.2 of the Splunk Add-on for Microsoft SCOM was released on June 30, 2020.

Compatibility

Version 3.0.2 of the Splunk Add-on for Microsoft SCOM is compatible with the following software, CIM versions, and platforms:

Component Description
Splunk platform versions 7.1.x, 7.2.x, 7.3.x, 8.0.0
CIM 4.14
Platforms Windows
Vendor Products Microsoft System Center Operations Manager 2012 R2

Microsoft System Center Operations Manager 2016 R2

Upgrade guide

Version 3.0.x of the Splunk Add-on for Microsoft SCOM is backwards compatible with version 2.3.0. All source types are the same and all inputs created using version 2.3.0 will continue to function.

Some events might be duplicated when you upgrade the Splunk Add-on for Microsoft SCOM on Splunk 7.3.x while the modular input script is running.

New features

Version 3.0.2 of the Splunk Add-on for Microsoft SCOM has the following new features.

  • Enhanced python library structure.

Fixed issues

Version 3.0.2 of the Splunk Add-on for Microsoft SCOM fixes the following issues. If no issues appear in this section, no issues have yet been fixed.

Known issues

Version 3.0.2 of the Splunk Add-on for Microsoft SCOM contains the following known issues.

If no issues appear in this section, no issues have yet been reported.

Version 3.0.1

Version 3.0.1 of the Splunk Add-on for Microsoft SCOM was released on March 19, 2020.

Compatibility

Version 3.0.1 of the Splunk Add-on for Microsoft SCOM is compatible with the following software, CIM versions, and platforms:

Component Description
Splunk platform versions 7.0.x, 7.1.x, 7.2.x, 7.3.x, 8.0.0
CIM 4.14
Platforms Windows
Vendor Products Microsoft System Center Operations Manager 2012 R2

Microsoft System Center Operations Manager 2016 R2

Upgrade guide

Version 3.0.x of the Splunk Add-on for Microsoft SCOM is backwards compatible with version 2.3.0. All source types are the same and all inputs created using version 2.3.0 will continue to function.

Some events might be duplicated when you upgrade the Splunk Add-on for Microsoft SCOM on Splunk 7.3.x while the modular input script is running.

New features

Version 3.0.1 of the Splunk Add-on for Microsoft SCOM has the following new features.

  • Restmap.conf updated to provide a flag that, by default, directs Splunk to run this add-on in Python3.

Fixed issues

Version 3.0.1 of the Splunk Add-on for Microsoft SCOM fixes the following issues. If no issues appear in this section, no issues have yet been fixed.

Known issues

Version 3.0.1 of the Splunk Add-on for Microsoft SCOM contains the following known issues.

If no issues appear in this section, no issues have yet been reported.

Version 3.0.0

Version 3.0.0 of the Splunk Add-on for Microsoft SCOM was released on December 17, 2019.

Compatibility

Version 3.0.0 of the Splunk Add-on for Microsoft SCOM is compatible with the following software, CIM versions, and platforms:

Component Description
Splunk platform versions 7.0.x, 7.1.x, 7.2.x, 7.3.x, 8.0.0
CIM 4.14
Platforms Windows
Vendor Products Microsoft System Center Operations Manager 2012 R2

Microsoft System Center Operations Manager 2016 R2

Upgrade guide

Version 3.0 of the Splunk Add-on for Microsoft SCOM is backwards compatible with version 2.3.0. All source types are the same and all inputs created using version 2.3.0 will continue to function.

Some events might be duplicated when you upgrade the Splunk Add-on for Microsoft SCOM on Splunk 7.3.x while the modular input script is running.

New features

Version 3.0.0 of the Splunk Add-on for Microsoft SCOM has the following new features.

  • Support for Splunk 8.0.x
  • Support for Python3

Fixed issues

Version 3.0.0 of the Splunk Add-on for Microsoft SCOM fixes the following issues. If no issues appear in this section, no issues have yet been fixed.

Known issues

Version 3.0.0 of the Splunk Add-on for Microsoft SCOM contains the following known issues.

If no issues appear in this section, no issues have yet been reported.

Version 2.3.0

Version 2.3.0 of the Splunk Add-on for Microsoft SCOM was released on August 06, 2019.

Compatibility

Version 2.3.0 of the Splunk Add-on for Microsoft SCOM is compatible with the following software, CIM versions, and platforms:

Component Description
Splunk platform versions 6.6.x, 7.0.x, 7.1.x, 7.2.x, 7.3.x
CIM 4.12
Platforms Windows
Vendor Products Microsoft System Center Operations Manager 2012 R2

Microsoft System Center Operations Manager 2016 R2

Upgrade guide

Version 2.3.0 of the Splunk Add-on for Microsoft SCOM is backwards compatible with version 2.2.0. All source types are the same and all inputs created using version 2.2.0 will continue to function.

Some events might be duplicated when you upgrade the Splunk Add-on for Microsoft SCOM on Splunk 7.3.x while the modular input script is running.

New features

Version 2.3.0 of the Splunk Add-on for Microsoft SCOM has the following new features.

  • Support for Splunk 7.3.x

Fixed issues

Version 2.3.0 of the Splunk Add-on for Microsoft SCOM fixes the following issues.

Known issues

Version 2.3.0 of the Splunk Add-on for Microsoft SCOM contains the following known issues.

If no issues appear in this section, no issues have yet been reported.

Version 2.2.0

Version 2.2.0 of the Splunk Add-on for Microsoft SCOM was released on June 21, 2018.

Compatibility

Version 2.2.0 of the Splunk Add-on for Microsoft SCOM is compatible with the following software, CIM versions, and platforms:

Component Description
Splunk platform versions 6.6.x, 7.0.x, 7.1.x, 7.2.x
CIM 4.4
Platforms Windows
Vendor Products Microsoft System Center Operations Manager 2012 R2

Microsoft System Center Operations Manager 2016 R2

Upgrade guide

Version 2.2.0 of the Splunk Add-on for Microsoft SCOM is backwards compatible with version 2.1.0. All source types are the same and all inputs created using version 2.1.0 will continue to function.

New features

Version 2.2.0 of the Splunk Add-on for Microsoft SCOM has the following new features.

  • Support for Microsoft SCOM 2016
  • Improved date support for various locales. Date inputs and datetime parameters are properly indexed.

Fixed issues

Version 2.2.0 of the Splunk Add-on for Microsoft SCOM fixes the following issues.

Known issues

Version 2.2.0 of the Splunk Add-on for Microsoft SCOM contains the following known issues.

If no issues appear in this section, no issues have yet been reported.

Version 2.1.0

Version 2.1.0 of the Splunk Add-on for Microsoft SCOM was released on September 21, 2016.

Compatibility

Component Description
Splunk platform versions 6.3, 6.4, 6.5, 6.6
CIM 4.3, 4.4, 4.5
Platforms Windows
Vendor Products Microsoft System Center Operations Manager 2012 R2

Upgrade instructions

Version 2.1.0 of the Splunk Add-on for Microsoft SCOM is backwards compatible with version 2.0.0. All source types are the same and all inputs created using version 2.0.0 will continue to function.

Since Splunk platform version 6.3 and higher contains a native PowerShell modular input, if you upgrade the Splunk platform version from 6.2 or earlier to 6.3 or later, you need to delete the Powershell add-on which was installed to collect data.

New features

Version 2.1.0 of the Splunk Add-on for Microsoft SCOM has the following new features.

  • Mapping to ITSI OS data model.
  • Support to collect performance metrics from monitors configured in Microsoft SCOM.
  • Support to set the start date of data collection.
  • Support to change the start time later than the time in the existing checkpoint file.

Known issues

Version 2.1.0 of the Splunk Add-on for Microsoft SCOM contains the following known issues.

Fixed issues

Version 2.1.0 of the Splunk Add-on for Microsoft SCOM has the following fixed issues.

Version 2.0.0

Version 2.0.0 of the Splunk Add-on for Microsoft SCOM is compatible with the following software, CIM versions and platforms:

Component Description
Splunk platform versions 6.3 or later
CIM 4.1 or later
Platforms Windows
Vendor Products Microsoft System Center Operations Manager 2012 R2

New features

  • Add support for separate console and management servers so that Splunk admins can pull data from SCOM environments where the console server and SCOM management servers are on separate machines.
  • Add support to collect data from nodes in a SCOM failover cluster.
  • UI updates for a better configuration experience.
  • Use Splunk platform 6.3 native PowerShell modular input rather than rely on the Splunk Add-on for Microsoft PowerShell.

Fixed issues

Version 2.0.0 of the Splunk Add-on for Microsoft SCOM contains the following fixed issues.

Known issues

Version 2.0.0 of the Splunk Add-on for Microsoft SCOM contains the following known issues.

Version 1.0.0

Version 1.0.0 of the Splunk Add-on for Microsoft SCOM has the same compatibility specifications as version 2.0.0.

New features

Version 1.0.0 of the Splunk Add-on for Microsoft SCOM has the following new features.

  • New Splunk-supported add-on.

Known issues

Version 1.0.0 of the Splunk Add-on for Microsoft SCOM has the following known issues.